https://www.acmicpc.net/problem/1926
문제
어떤 큰 도화지에 그림이 그려져 있을 때, 그 그림의 개수와, 그 그림 중 넓이가 가장 넓은 것의 넓이를 출력하여라. 단, 그림이라는 것은 1로 연결된 것을 한 그림이라고 정의하자. 가로나 세로로 연결된 것은 연결이 된 것이고 대각선으로 연결이 된 것은 떨어진 그림이다. 그림의 넓이란 그림에 포함된 1의 개수이다.
입력
첫째 줄에 도화지의 세로 크기 n(1 ≤ n ≤ 500)과 가로 크기 m(1 ≤ m ≤ 500)이 차례로 주어진다. 두 번째 줄부터 n+1 줄 까지 그림의 정보가 주어진다. (단 그림의 정보는 0과 1이 공백을 두고 주어지며, 0은 색칠이 안된 부분, 1은 색칠이 된 부분을 의미한다)
출력
첫째 줄에는 그림의 개수, 둘째 줄에는 그 중 가장 넓은 그림의 넓이를 출력하여라. 단, 그림이 하나도 없는 경우에는 가장 넓은 그림의 넓이는 0이다.
예제 입력
6 5
1 1 0 1 1
0 1 1 0 0
0 0 0 0 0
1 0 1 1 1
0 0 1 1 1
0 0 1 1 1
예제 출력
4
9
BFS풀이
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.LinkedList;
import java.util.Queue;
public class Main {
static int n;
static int m;
static int dx[] = {1, 0, -1, 0}; // 아래부터 반시계방향으로
static int dy[] = {0, 1, 0, -1};
static boolean[][] visited;
static int[][] board;
static int count = 0;
static int maxArea = 0;
public static void main(String[] args) {
BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
try {
String[] nums = br.readLine().split(" ");
n = Integer.parseInt(nums[0]);
m = Integer.parseInt(nums[1]);
visited = new boolean[n][m];
board = new int[n][m];
for (int i = 0; i < n; i++) {
String[] temp = br.readLine().split(" ");
for (int j = 0; j < m; j++) {
board[i][j] = Integer.parseInt(temp[j]);
}
}
for (int i = 0; i < n; i++) {
for (int j = 0; j < m; j++) {
if (visited[i][j] || board[i][j] == 0) continue;
count++;
Queue<Pair<Integer, Integer>> queue = new LinkedList<>();
visited[i][j] = true;
queue.add(new Pair(i, j));
int area = 0;
while (!queue.isEmpty()) {
area++;
Pair<Integer, Integer> cur = queue.peek();
queue.poll();
for (int dir = 0; dir < 4; dir++) {
int nx = cur.first + dx[dir];
int ny = cur.second + dy[dir];
if (nx < 0 || nx >= n || ny < 0 || ny >= m) continue;
if (visited[nx][ny] || board[nx][ny] == 0) continue;
visited[nx][ny] = true;
queue.add(new Pair(nx, ny));
}
}
// i, j 기준 BFS 종료
maxArea = Math.max(maxArea, area);
//System.out.println(maxArea);
//System.out.println(count + i +","+ j);
}
}
System.out.println(count);
System.out.println(maxArea);
} catch (IOException e) {
e.printStackTrace();
}
}
}
class Pair<I extends Integer, I1 extends Integer> {
Integer first;
Integer second;
public Pair(Integer first, Integer second) {
this.first = first;
this.second = second;
}
public Integer first() {
return first;
}
public Integer second() {
return second;
}
}
DFS 풀이
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.Stack;
public class Main {
static int n;
static int m;
static int dx[] = {1, 0, -1, 0}; // 아래부터 반시계방향으로
static int dy[] = {0, 1, 0, -1};
static boolean[][] visited;
static int[][] board;
static int count = 0;
static int maxArea = 0;
public static void main(String[] args) {
BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
try {
String[] nums = br.readLine().split(" ");
n = Integer.parseInt(nums[0]);
m = Integer.parseInt(nums[1]);
visited = new boolean[n][m];
board = new int[n][m];
for (int i = 0; i < n; i++) {
String[] temp = br.readLine().split(" ");
for (int j = 0; j < m; j++) {
board[i][j] = Integer.parseInt(temp[j]);
}
}
for (int i = 0; i < n; i++) {
for (int j = 0; j < m; j++) {
if (visited[i][j] || board[i][j] == 0) continue;
count++;
Stack<Pair<Integer, Integer>> stack = new Stack<>();
visited[i][j] = true;
stack.push(new Pair(i, j));
int area = 0;
while (!stack.isEmpty()) {
area++;
Pair<Integer, Integer> cur = stack.peek();
stack.pop();
for (int dir = 0; dir < 4; dir++) {
int nx = cur.first + dx[dir];
int ny = cur.second + dy[dir];
if (nx < 0 || nx >= n || ny < 0 || ny >= m) continue;
if (visited[nx][ny] || board[nx][ny] == 0) continue;
visited[nx][ny] = true;
stack.push(new Pair(nx, ny));
}
}
// i, j 기준 BFS 종료
maxArea = Math.max(maxArea, area);
}
}
System.out.println(count);
System.out.println(maxArea);
} catch (IOException e) {
e.printStackTrace();
}
}
}
class Pair<I extends Integer, I1 extends Integer> {
Integer first;
Integer second;
public Pair(Integer first, Integer second) {
this.first = first;
this.second = second;
}
public Integer first() {
return first;
}
public Integer second() {
return second;
}
}
설명
DFS나 BFS 둘다 사용가능하고 스택, 큐의 사용 차이점 밖에 없다.
알아야 할 것
큐나 스택에 넣기전에 방문을 표시하고 큐나 스택에 넣는다는 것.
큐나 스택에서 빼고 난 후 방향체크를 하고 0이 아니거나 방문하지 않았을 경우 해당 지점을 큐나 스택에 넣는다는 점